Using This Book with Excel 2007

The upcoming release of Microsoft Excel 2007 has a number of improvements that
make financial models more powerful and capable of handling larger amounts of
data. The most obvious changes are graphical, namely a noticeable update to the
toolbar command system, which allows faster access to controls for formatting
and manipulating spreadsheet data. There is also a vast expansion of the maximum
number of rows and columns. Figure A.1 shows the new look of Excel 2007’s default
workbook window. A very important new feature is Excel’s improved use of memory.
Formula calculation methodologies have also been made more efficient. Both speed
up total workbook calculation time. While it may take a few years before companies
switch over to Excel 2007, small businesses and tech-savvy individuals will want to
run Excel 2007 now—and they will need to know how it affects this book.
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FIGUREA.1 Microsoft Excel 2007’s default workbook window.

179



180

USING THIS BOOK WITH EXCEL 2007

Overall, the difference between Excel 2007 and earlier versions will have no
impact on the functionality of the Project Model. However, a few of the step-by-step
instructions will need to be performed differently due to the new tabbed Ribbon
system that Excel 2007 uses. Instead of the menu bar selections commonly found
on Microsoft Office 2000, 2002, and 2003 applications—File, Tools, Format, and
the like—Excel 2007 uses a Ribbon and various tabs that reorganize and access
commonly used controls. Accessing those operations is more graphical and icon-
based rather than menu driven. This affects the creation of data validation lists,
pasting formats, inserting names, adding worksheets, using Goal Seek, and opening
the Visual Basic Editor (VBE). Instead of using the menu commands to access these
operations, the Ribbon system is used by clicking on the appropriate button. (The
keyboard shortcuts still remain and can be used to quickly use many of those
operations.) Using operations and tools relevant to this book in Excel 2007 have
been detailed in this appendix.

The other obvious change is the virtual elimination of row and column con-
straints, which changes one important concept in this book. Early in the book, it is
stated that for Excel 2003 and prior versions there are row and column constraints
that dictate the vertical or horizontal time progression of the model. Given that
Excel 2007 offers 16,000 columns and over 1 million rows per sheet, the decision to
have time progress vertically or horizontally is irrelevant. However, most structured
models are formatted with period progression going vertically; to maintain con-
vention and the ease of use for other structured modelers—this method should be
used. There are other areas in financial modeling where the elimination of the row
and column constraints are particularly useful, such as working with loan level data
tapes. But keep in mind that you are still constrained by the computer’s memory and
Excel’s allocation of that memory. That said, Excel 2007 has relatively little impact
on this book because the real value lies in the theory, and the formula and functions
that translate that theory into a model. Aside from a handful of functions that have
undergone some extremely minor alterations, all of the functions are the same. This
means that using the functions in the formulas as the book instructs will produce a
consistent result regardless of the Excel version being used.

GUIDE TO OPERATIONS AND FUNCTIONS IN EXCEL 2007
RELEVANT TO THIS BOOK

Data Validation

Data validation is used throughout this book in order to create drop-down lists in
cells. The list values are stored on the Hidden sheet, named as ranges, and are used
on the inputs sheet through the data validation tool. To use this tool in Excel 2007:

1. Make the cell that requires the data validation list the active cell.
2. Click the Data tab and then click Data Validation in the Data Tools group. See
Figure A.2.
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FIGURE A.2 Location of Data Validation on the Data tab.

3. On the Settings tab and under Validation criteria, click List in the Allow
drop-down list.

4. Enter the named range of the list data in the Source box.

5. Click OK.

Cell Formatting

Most formatting in Excel 2007 is found on the Home tab shown in Figure A.3.
From there the format can be set using options in the Font, Alignment, Number,
and Styles boxes. In particular Excel 2007 has a number of new features that make
cell formatting easier to use and more robust.

Still, one of the most useful features is the Format Painter, now located in Excel
2007 in the Clipboard group on the Home tab. This feature works by clicking on a
cell with a desired format, clicking the Format Painter button, and then clicking on a
different cell where the format should be applied. For cells that are not contiguous,
double-clicking the Format Painter keeps it selected.

There are preset cell styles that makes customizing a worksheet faster. These
can be found in the Styles group on the Home tab by clicking the Cell Styles button.
Custom styles can be selected on the Cell Styles palette—and be created here and
saved on this palette for quick access.
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FIGUREA.3 Common formatting tools are found on the Home tab.

Conditional Formatting

In Chapter 8, conditional formatting is used for cells with logic tests to make it clear
to the user that the model is either working properly or not. Conditional formatting
is located in the Styles group on the Home tab box shown in Figure A.4.
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Excel 2007 has greatly expanded the conditional formatting options, which is
evident when the Conditional Formatting button is clicked. Instead of opening a
dialog box, as was the case in Excel 2003 and earlier, a menu opens that allows you
to select the desired conditional formatting from its corresponding submenu.

To create the conditional formatting used in this model:

1. Click the Conditional Formatting button in the Styles group on the Home tab.

2. Click Highlight Cells Rules to open its menu.

The logic tests in Chapter 8 worked off of either TRUE or FALSE return values.
This requires making the cell formatting conditional on whether its value is
equal to either TRUE or FALSE. The correct option from Highlight Cells Rules
menu is Equal To...

3. Click Equal To ... The Equal to dialog box appears. In the Format cells that
are EQUAL TO: box enter TRUE.

4. Inthe drop-down list to the right, select the desired conditional formatting format-
ting that should be applied when the rule is valid. Click Green Fill with Dark Green
Text. This is an excellent option if everything is working properly. Otherwise a
custom format can be selected as the last option in the drop-down list.

5. Repeat steps 1 through 4 to set the conditional formatting for the FALSE value.
Select Red Fit with Dark Red Text as the cell formatting to indicate errors.

Clicking the Conditional Formatting button also gives you access to such
conditional formatting options as data bars, color scales, and icon sets. These are
particularly useful features in financial modeling to quickly see the differences in
values or trends over time.

To create your own custom conditional formats, click the Conditional Format-
ting button and select New Rule from the menu. The New Formatting Rule dialog
box opens (shown in Figure A.5). This allows you to select your own options for
creating custom conditional formatting rules.
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FIGUREA.8 The New Formatting Rule dialog box allows you
to create custom conditional cell formats.

Ranges can still be named quickly in Excel 2007 by clicking Name Box list in the
top left corner of the worksheet.

Excel 2007 now has its powerful naming features on the Formulas tab. Here
you will find the Defined Names group, which contains such controls as the Define
Name and Name Manager buttons (see Figure A.6). Ranges are named using the
Define Name button. Clicking it opens the New Name dialog. Here the range is
named, its parameters defined for either the entire workbook or a specific sheet,
comments can be entered, and the reference selected. For preexisting named ranges,
clicking the Name Manager allows you to access the desired range to make edits.
The Name Manager dialog box also shows the value of the named cell, what the
cell’s reference is, whether it is set to the entire workbook or a specific sheet, and
any comments. New names can also be created from this dialog box.
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FIGUREA.6 The Defined Names group controls on the Formula tab.

Adding Worksheets

Excel 2007 has a very convenient shortcut for adding new worksheets. At the bottom
of the workbook, where the sheet tabs are located, click the Insert Worksheet button
tab, indicated by a worksheet icon with an asterisk shown in Figure A.7. If you don’t
see the Insert Worksheet button, which can happen in multisheet workbooks, click
or scroll to the rightmost worksheet tab.
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FIGUREA.7 Click the Insert
Worksheet button to create a new
worksheet.
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Goal Seek Tool

To use the Goal Seek function in Excel 2007, click the Data tab and then click
the What-If Analysis button in the Data Tools group. Select Goal Seek from the
drop-down list. This opens the Goal Seek dialog box as in previous versions of Excel
(see Figure A.8).
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FIGUREA.8 Click the What-If
Analysis button in the Data Tools
group to select Goal Seek.

Add-Ins

The Analysis ToolPak and the Analysis ToolPak—VBA are Excel add-ins that
provide Excel with more functionality such as the EDATE function used in this
book. To access Excel add-ins and activate either or both Analysis ToolPaks, use
the following steps:

1. Click the Microsoft Office button in the top-left corner of the Excel window.

2. On the bottom of the menu, click Excel Options. The Excel Options dialog box
opens (see Figure A.9).

3. Click Add-Ins in the options category list.

The Add-ins pane opens. Note that it is divided into two lists: Active Application
Add-ins and Inactive Application Add-ins.

4. Select the desired add-in from the Inactive Application Add-ins list. In this case,
you would select either Analysis ToolPak or Analysis ToolPak—VBA.

5. Click the Go button.

6. In the Add-Ins dialog box, select the desired options. If you selected Analysis
ToolPak, you can also include the VBA option.

7. Click OK.
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FIGUREA.9 Excel Options dialog box allows you access to Excel Add-Ins and other
Excel application options.
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FIGUREA.10 Add-ins dialog box options for Analysis ToolPak.

Visual Basic Editor

The Visual Basic Editor is still accessed by pressing Alt + F11.To have macro and
Visual Basic options available as a tab, you must activate the Developer tab in Excel
Options.
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FIGUREA.11 Click in the Show Developer tab in the Ribbon checkbox
select this option and access Visual Basic options in the Excel 2007
window.

Aod-[as

1. Click the Microsoft Office button in the top-left corner of the Excel window.

2. On the bottom of the menu, click Excel Options. The Excel Options dialog box
opens

3. Click Popular in the options category list.

4. In the Popular pane, select the Show Developer tab in the Ribbon checkbox (see
Figure A.11).

5. Click OK.

These steps will create the Developer tab in the ribbon and allow for easy access
to code, VBA control, and XML options.

Please note that this appendix was created using a Beta version of Excel
2007. Command processes and graphics may have changed in the final
release version.



